[Home] [Downloads] [Search] [Help/forum]


Register forum user name Search FAQ

Gammon Forum

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  Color issue on one server

Color issue on one server

You need to log onto the forum to reply or create new threads.

  [Refresh] Refresh page


Posted by Fearless   (8 posts)  [Biography] bio
Date Mon 13 May 2024 02:38 AM (UTC)
Message
bbs.game-master.com port 23 is monochrome in Mushclient but it has color in Putty. I suspect the server is doing some kind of ANSI feature check with the client. Is there any hope of working around this? I have no idea where to start.
[Go to top] top

Posted by Nick Gammon   Australia  (23,003 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Mon 13 May 2024 08:53 PM (UTC)

Amended on Mon 13 May 2024 08:57 PM (UTC) by Nick Gammon

Message
I just connected and made a new account, and it all appeared in colour, see below:



As far as I know MUSHclient renders in colour automatically, I don't think there is any negotiation. I did get asked initially if I could see colours, as below:


The following word may or may not be colored or blinking: ANSI
Is it colored or blinking (Y/N)?  y

Good!  Your answer has been recorded.



You may have to change some account setting on the server side for it to send you colours.

Template:version Please help us by advising the version of MUSHclient you are using. Use the Help menu -> About MUSHclient.





The rendering of some characters looks odd, you may have to change the settings for that too.


GM's Main Menu (MAIN)
Make your selection (G,T,E,F,L,M,V,D,R,? for help, or X to exit):  

ÄÄ Ú¿¿¿Ú¿ Ú¿Ú¿Ú¿ڿڿ¿Ú¿Ú¿ÂÚ¿Ú¿ ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ
ÄÄÄ ³ ôà  ³¿Ã´³ ³Ã ³³³Ã´À¿³Ã ÿ ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ Main Menu ÄÄ
ÄÄÄ ³ ÙÙÀÙ ³³ÙÙÙ ÙÀÙ³ ³ÙÙÀÙÙÀÙÙÀ ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ
ÚÀÙ ÙÞ ÀÙÀ¿ÀÙÀٿٳٳ٠٠ÄÃÚÞÞ Ùô³¼º¿Àͼ´ÃÄÙ´ÃÚÄ¿ÀÞÞ ÍÄ´³Ù´ÃÚͼ´ÙóÄÚ¿´³ÌóÀÄó
»ÃÚÍÝÝÝÙijĿɴ³ÀÙô³ÄÚº³ÀÙÃÝÝÝ»ÄȻڿ´ÄÀÙ´ÍÚÌ¿ÀÃÍÙÌÝÝÝûÀÙ´Ìͼ¿ÀÃÌÙijÚÍ´ÄÀͼ»ÄÚÍ
»¼ÍÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ¿¼ÚÍ¿
¿ÌͳÞGÝ Games              ÞEÝ Electronic Mail    ÞLÝ File Library      Þ ³ÀÙÌ
»ÚijÞTÝ Teleconference     ÞFÝ Public Forums                            ÞݳÀÙ³Ù
³¼Ã³                       ÞVÝ Voting Polls                            ÞÝ ³ÀÙÍ»
ÌÍÁ³ÞMÝ Member's Corner    ÞDÝ Daily History      ÞRÝ Registry of Users ß ³ÈÙ³³
ÁÙÚ³                                                                  Þ Þ Ý  »¼
ûÙÀÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÞ ÄÄÞÞÞÞÝÞ  Ù
»¼ÍÌÞÞ Ì´Ä¼À¼Ã¹Ä³¿Àٴ̼ÄÚ¿ÀÞÞ ÌÄôÄÚ¿À³ÄÚ¿ÍÙóÄû³ÞÞ À¿ÙÍÃÀ³Í¿ÙÀ³  Ý  ÞÞÛÞ  Þ
ڴóÝÝÝ¿ÀóĴÌÚÄ¿ÀÙô³Ä¼Í»ÄÝÝÝÈٳĻ¼³ÀÄÚ¼ÍٳͼÚÌ¿ÃÝÝÝÙÀ»Ã»¼Ã³ÀÍ̳  ß   ÞÛÞ  ß
´»Í»ÝÝÝÀ¼¼Í»¿Ä³Í¼´Ì³ÄÚ¿³ÃÙÄÝÝÝÄÈ¿À³ÃÙÄóÄڿ̳ÃÙÄ´ÍÝÝݼÀ´Ã³Ä¿ÍÚ³Ù» ÞÞÞ  ÞÛÞ ÞÞÞ
ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ ÞÞ ßßßßß ÞÞÄ
ÄÄ[67  Other Users Online    ]ÄÄÄÄÄÄÄ Online Rules: "/GO RULES" Ä ßßßß ²Û± ßßßß
ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ ÄÄ Þ Ä ²Û± Ä ÝÄ
ÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ ßßß Ü ßßß Ä
                                                                                


Try turning on UTF-8 in the Output configuration tab.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Fearless   (8 posts)  [Biography] bio
Date Reply #2 on Tue 14 May 2024 12:02 AM (UTC)
Message
Thanks, Nick!

I'm using 5.06 and I'm still stumped. I extracted the mushclient installer to a new folder to avoid my personal settings but I still have the same problem. I tried on Windows 10 and Lubuntu with wine 9.0.

With Mushclient, I get monochrome ASCII before the logon prompt and also after logging on. With Putty, I get color before the logon prompt and also after logging on the same account.
[Go to top] top

Posted by Nick Gammon   Australia  (23,003 posts)  [Biography] bio   Forum Administrator
Date Reply #3 on Tue 14 May 2024 08:08 AM (UTC)
Message
Yeah, but, if your account is configured to not serve up colours, that is exactly what you would expect. Check the server for an option to show colours.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Nick Gammon   Australia  (23,003 posts)  [Biography] bio   Forum Administrator
Date Reply #4 on Tue 14 May 2024 08:08 AM (UTC)
Message
Make a new account just to test this theory.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Nick Gammon   Australia  (23,003 posts)  [Biography] bio   Forum Administrator
Date Reply #5 on Tue 14 May 2024 08:10 AM (UTC)

Amended on Tue 14 May 2024 08:15 AM (UTC) by Nick Gammon

Message
It might be something to do with the "termtype" query.

There is not a query, as far as I remember, to say whether or not the client supports colours. But the "Telnet Terminal Type" might influence the server. Check the Output configuration page (bottom RH corner).

Try setting it to "xterm" which appears to be the putty default.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Fearless   (8 posts)  [Biography] bio
Date Reply #6 on Wed 29 May 2024 11:01 PM (UTC)
Message
I enabled color by having this in a trigger:
SendPkt(string.char(27).."[5;26R")

Explanation:
The BBS probably sends ESC[6n and checks to see if the client responds with the cursor position, which is what the trigger output is faking. The two integer values don't seem to matter. That was just my guess about where the cursor would be. I think I am triggering on the line before ESC[6n is sent because I think the BBS detection scheme will not end with a newline. Either my timing is lucky or the BBS buffers my SendPkt data.

I made many assumptions but it works. No, I am not going to spend all year learning how to use Wireshark to verify any of this. :)
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


652 views.

You need to log onto the forum to reply or create new threads.

  [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at HostDash]